//
you're reading...
Mikrotik

SETTING BANDWIDTH


1. Setting Bandwidth Limiter (gunakan winbox)
A. klik menu ip>Firewall>magle -buat rule (klik tanda plus merah) dengan parameter sebagai berikut: -pada tab General : Chain=forward, Src.address=192.168.0.2 (atau ip yang ingin di limit) -pada tab Action=mark connection, New connection mark=ropix-con (atau nama dari mark conection yang kita buat) -klik Apply dan OK -Buat rule lagi dengan parameter sebagai berikut: -Pada tab General: Chain=forward, Connection mark=ropix-con (pilih dari dropdown menu) -pada Action=mark packet, New pcket Mark=ropix(atau nama packet mark yang kita buat) -Klik Apply dan OK B. Klik menu Queues>Queues Tree -Buat rule (klik tanda plus warna merah) dengan parameter sebagai berikut: -pada tab General: Nama=ropix-downstrem (misal), Parent=ether2 (adalah interface yang keluar ke internet), Paket Mark=ropix (pilih dari dropdown, sama yang kita buat pada magle), Queue Type=default, Priority=8, Limit At=8k (untuk bandwidth minimum), Max limit=64k (untuk setting bandwidth brustable) -klik Aplly dan OK -Buat rule dengan parameter sebagai berikut: -pada tab General: Nama=ropix-upstrem (misal), Parent=ether1 (adalah interface yang kedalam), Paket Mark=ropix (pilih dari dropdown, sama yang kita buat pada magle), Queue Type=default, Priority=8, Limit At=8k (untuk bandwidth minimum upstrem), Max limit=64k (untuk setting bandwidth brustable) -klik Aplly dan OK C. Cobalah browsing dan download dari ip yang kita limit tadi, Rate pada Queues rule tadi harus mengcounter, kalo belum periksa lagi langkah-langkah tadi D. icon hijau menandakan bandwidth kurang dari batasan, icon berubah kuning berarti bandwidth mendekati full dan merah berarti full.
Ada lagi nih buat beda limit siang malam
-Andaikan kita punya jaringan 192.168.1.0/24 dan mau dilimit berdasarkan siang dan malam hari

Network 192.168.1.0/24
Bandwidth = 06:00am – 18:00pm – 1Mbps. 
Bandwidth = 18:00pm – 06:00am – 2Mbps. 

-Buat 2 Simple Queue untuk jaringan LAN yg sama dengan beda bandwidth.

/queue simple
#name=”Siang” target-addresses=192.168.1.0/24 dst-address=0.0.0.0/0
interface= parent=none direction=both priority=8
queue=default-small/default-small limit-at=512k/512k
max-limit=1M/1M total-queue=default-small

#name=”Malam” target-addresses=192.168.1.0/24 dst-address=0.0.0.0/0
interface= parent=none direction=both priority=8
queue=default-small/default-small limit-at=1M/1M
max-limit=2M/2M total-queue=default-small

-Sekarang, buat script nya
/system script #name=”Siang” source=/queue simple enable Siang; /queue simple disable Malam #name=”Malam” source=/queue simple enable Malam; /queue simple disable Siang

Jika script yang diberi nama “Siang” dieksekusi,script tersebut akan mengenable simple queue yang diberi nama “Siang dan mendisable simple queue “Malam” Untuk script yang malam adalah sebaliknya

Akhirnya, jadwalkan!

/system scheduler
#name=”Siang” on-event=Siang start-date=may/15/2008 start-time=06:00:00 interval=1d
#name=”Malam” on-event=Malam start-date=may/15/2008 start-time=18:00:00 interval=1dNah di dalam scheduler dijelaskan,

Scheduler yang diberi nama “Siang” akan mengeksekusi script yang diberi nama “Siang” dimulai tanggal 15 may 2008 pada jam 06.00 dengan interval
1 hari.

Scheduler yang diberi nama “Malam” akan mengeksekusi script yang diberi nama “Malam” dimulai tanggal 15 may 2008 pada jam 18.00/ jam 6 sore
dengan interval 1 hari.

2. Setting Proxy

A. Set si proxy /ip web-proxy set enabled=yes –>> enable si proxy set src-address=0.0.0.0 –>> alamat yg di allow set port=8080 –>> port proxy set hostname=”proxy.zulfanruri.com” –>> visible hostname si proxy set transparent-proxy=yes –>> enable transparent proxy set parent-proxy=0.0.0.0:0–>> jika kita gunakan parent proxy set cache-administrator=”support@zulfanruri.com” –>> email admin proxy set max-object-size=4096KiB –>> max size object yg bisa di tangkap si proxy set cache-drive=system –>> tempat penyimpanan cache set max-cache-size=unlimited –>> max harddrive yg digunakan sbg cache set max-ram-cache-size=unlimited –>> max ram yg digunakan sbg cache

B. Tambahkan nat utk redirect port ke squid /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 –>> redirect port 80 ke 8080 /ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080 –>> redirect port 3128 ke 8080 /ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=8080 –>> redirect port 8080 ke 8080
3. Blok Situs A. Setelah itu anda ketikan kode berikut :[admin@Mikrotik] ip web-proxy> set enabled=yes port=8080 max-object-size=131072 hostname=admin transparent-proxy=yes cache-administrator=admin@gmail.com B. Kemudian ketikan kode berikut:[admin@Mikrotik] ip web-proxy> print , Maka akan muncul kata-kata berikut : enabled: yes src-address: 0.0.0.0 port: 8080 hostname: 83h0m8 transparent-proxy: yes parent-proxy: 0.0.0.0:0 cache-administrator: 83h0m8@gmail.com max-object-size: 131072 KiB cache-drive: system max-cache-size: none max-ram-cache-size: unlimited status: running reserved-for-cache: 3514368KiB reserved-for-ram-cache: 19456KiB C. Dan untuk membuat transparent ketikan kode berikut : [admin@Mikrotik]/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 D. Nah sekarang buat rule di firewall filter agar tidak jdi open proxy, ketikan kode berikut : [admin@Mikrotik]/ip firewall filter add chain=input in-interface= “interface dari internet” src-address=0.0.0.0/0 protocol=tcp dst-port=8080 action=drop Interface dari internet disini adalah nama interface di Router anda yang terhubung ke Internet, contoh : speedy E. Dan sekarang kita masukan rule untuk mem-block situs-nya..!! Misal kita akan memblok situs “www.sex.com”maka ketikan kode berikut : [admin@Mikrotik]/ip web-proxy access add url=”sex.com” action=deny comment=”” disabled=no F. Dan seterusnya…. Nah jika kita ingin mem-block situs dengan cara “kata2 tertentu akan kita block, contoh kita akan block kata “sex” maka ketikan kode berikut : [admin@Mikrotik]/ip web-proxy access add url=”sex” action=deny comment=”” disabled=no

Diskusi

One thought on “SETTING BANDWIDTH

  1. nice info gan… mampi ya ke blog aku sekalian tukeran link

    Posted by Yoyox Computer | 31 Agustus 2009, 12:35 pm

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: